Supported Magento versions

Magento versions are available since magento-scripts 1.5.0

When you first starting the application, you will see the following prompt:

Magento version prompt

Here you can choose the Magento version to install.

Supported versions

Magento 2.4.1

This version will use the following configuration as default, you can override it on the configuration file.

{
php: {
version: '7.4.13',
extensions: {
gd: {},
intl: {},
zlib: {},
openssl: {},
sockets: {},
SimpleXML: {},
xdebug: {
version: '3.0.4'
}
}
},
nginx: {
version: '1.18.0'
},
redis: {
version: '6.0.10-alpine'
},
mysql: {
version: '8.0'
},
mariadb: {
version: '10.4'
},
elasticsearch: {
version: '7.12.1'
},
composer: {
version: '1'
}
}

Magento 2.4.1-p1

This version will use the following configuration as default, you can override it on the configuration file.

{
php: {
version: '7.4.16',
extensions: {
gd: {},
intl: {},
zlib: {},
openssl: {},
sockets: {},
SimpleXML: {},
libsodium: {
extensionName: 'sodium'
},
xdebug: {
version: '3.0.4'
}
}
},
nginx: {
version: '1.18.0'
},
redis: {
version: '6.0.10-alpine'
},
mysql: {
version: '8.0'
},
mariadb: {
version: '10.4'
},
elasticsearch: {
version: '7.12.1'
},
composer: {
version: '1'
}
}

Magento 2.4.2

This version will use the following configuration as default, you can override it on the configuration file.

{
php: {
version: '7.4.18',
extensions: {
gd: {},
intl: {},
zlib: {},
openssl: {},
sockets: {},
SimpleXML: {},
libsodium: {
extensionName: 'sodium'
},
xdebug: {
version: '3.0.4'
}
}
},
nginx: {
version: '1.18.0'
},
redis: {
version: '6.0.10-alpine'
},
mysql: {
version: '8.0'
},
mariadb: {
version: '10.4'
},
elasticsearch: {
version: '7.12.1'
},
composer: {
version: '2'
}
}

If you change the composer version it might not work. Magento 2.4.2 requires Composer 2.